Jump to content

Search the Community

Showing results for tags 'iis'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • uniGUI Public
    • Announcements
    • General
    • Feature Requests
    • Installation
    • Deployment
    • Other Platforms
  • Licensing
    • Licensing
    • Ordering uniGUI
  • Bug Reports
    • Active Reports
    • Closed Reports
    • Old Bug Reports
  • uniGUI Development
    • uniGUI 1.x
    • Beta Releases
    • Utilities
  • Mobile Platform
    • uniGUI Mobile
    • Mobile Browsers
  • Users Area
    • Sample Projects
    • Components and Code Samples
  • Non-English
    • Non-English
  • Miscellaneous
    • Hosting
    • Server Security
    • Jobs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 15 results

  1. how can unigui get the windows logon User id and Domain (using AD) during ISAPI launching ? Eg. 1.) User login into Windows using Active Directory authentication 2.) User Launching ISAPI web application (IIS), here need to read the User id and Domain entered during step 1 3.) Application go to main page if User id/Domain is valid, otherwise go to Login page
  2. Hi, I'm using IIS 10, Hyper_Server 1.70.0.1486 with my application. When I run application in standalone mode, response looks like: most important: HTTP/1.1 200 OK But when I use IIS + hyper_server, response is WITHOUT "OK" ... HTTP/1.1 200 Embeded device is waiting for that OK also, response is not parsed. Can you please help me ? Thanks. HTTP/1.1 200 OK Connection: close Content-Type: text/plain; charset=us-ascii Content-Length: 4 Date: Mon, 08 Jun 2020 10:10:04 GMT Server: New Application OK|0 HTTP/1.1 200 Content-Type: text/plain; charset=us-ascii Server: Microsoft-IIS/10.0 Server: New Application Date: Mon, 08 Jun 2020 10:10:28 GMT Content-Length: 4 OK|0
  3. How do I detect the browser that is running the application? Because this code only works right when I run in debugger: var C: TUniClientInfoRec; begin label_ra.Caption: = UniApplication.RemoteAddress; C: = UniApplication.ClientInfoRec; label_bt.Caption: = C.BrowserType; label_bv.Caption: = IntToStr (C.BrowserVersion); label_os.Caption: = C.OSType; But when I run inside Apache or IIS, it is not returning me anything, it comes in white.
  4. Esteemed, We are working in production with a windows server 2012 server, IIS and HyperServer, greatly improved performance and instability, but sometimes during the day the crash occurs. Attachments: index.cfg, log index.dll, and logs for some nodes, The errors started at 13:49:12 version uniGUI 1.90.0.1531 I appreciate the collaboration. index.cfg index.dll A2020-06-18.log n0 A2020-06-18.log n1 A2020-06-18.log n2 A2020-06-18.log
  5. Разместил приложение на IIS, после нескольких часов стабильной работы приложение падает. Все динамически созданные объекты почищаются, была сделана проверка на утечку памяти. В чем может быть причина .dll: 00003C2C: 02:10:14 [172.17.1.235]:Session <28Dg1VVipo1059662B4> Created. .dll: 00003C2C: 02:10:14 [HttpExtensionProc[172.17.1.235]]:EAccessViolation : Access violation at address 0704E328 in module 'Test.dll'. Read of address 00000008 : Addr: $0704E328 .dll: 00003C2C: 02:10:19 [172.17.1.235]:Session <M5xz7t1iWD1059662BB> Created. .dll: 00003C2C: 02:10:19 [HttpExtensionProc[172.17.1.235]]:EAccessViolation : Access violation at address 0704E328 in module 'Test.dll'. Read of address 00000008 : Addr: $0704E328 .dll: 00003C2C: 02:10:23 [172.17.1.235]:Session <l4EREpdj551059662BF> Created. .dll: 00003C2C: 02:10:24 [HttpExtensionProc[172.17.1.235]]:EAccessViolation : Access violation at address 0704E328 in module 'Test.dll'. Read of address 00000008 : Addr: $0704E328 .dll: 00000D44: 02:10:25 [172.17.1.235]:Session <TZjKvNViXY1059662C1> Created. .dll: 000029D8: 02:10:46 [172.17.1.235,89.37.27.218]:Session <28Dg1VVipo1059662B4> Terminated. Reason: Shadow Session Terminated. .dll: 000029D8: 02:10:51 [172.17.1.235,89.37.27.218]:Session <M5xz7t1iWD1059662BB> Terminated. Reason: Shadow Session Terminated. .dll: 000029D8: 02:10:56 [172.17.1.235,89.37.27.218]:Session <l4EREpdj551059662BF> Terminated. Reason: Shadow Session Terminated.
  6. Hi, I'm using nginx to redirect my unigui applications on IIS, but I need help to setting up. When nginx redirects an application to location, the files sources don't work. I've alredy tried to change ExtRoot and UniRoot, but without success. nginx conf upstream amteste { server localhost:91; } server { listen 80; proxy_set_header X-Real-IP $remote_addr; proxy_set_header Host $host:$server_port; location = /amteste { return 301 /amteste/; } location /amteste/ { proxy_pass http://amteste/; } } Is it possible? Any idea?
  7. Problems with two Unigui Applications on the same IIS Server Good afternoon, I have two Unigui applications running on IIS. One at port 81 and one at port 82. But if I open http: // localhost: 81, and then open a new window and try to open it to http: // localhost: 82, it keeps loading http: // localhost: 81 and in that situation I have to keep giving Ctrl + F5 several times until it opens at http: // localhost: 82. Once you have opened http: // localhost: 82 it is the APP http: // localhost: 81 which gives the same problem. How do I fix this? I already researched but could not find material or a solution. Note ..: PHP sites work normal, the problem is with applications made with Unigui. This happens if you try to open in the same browser (Tested in Chrome) Follows the images of the Pool configuration of the two applications APP 01 APP 02
  8. Hi Guys, Just after a bit of advice about deployment. Here is my scenario.. (If I am ever lucky enough to have lots of customers for my application - this is a good problem to have!) Let’s say I own www.uniguiapp.com I am using a VM which can scale to a certain degree(I can add more RAM and CPU cores etc.) Lets say for now the limit of the server is 2 customers. I have my application deployed on IIS – Underneath an application pool I have a site for each “Customer” eg. www.uniguiapp.com/customer1 goes to the application and connects to customer1’s database (on the same SQL server instance) www.uniguiapp.com/customer2 goes to the application and connects to customer2’s database (on the same SQL server instance) Each folder on the file system has its “own instance off the unigui application, eg its own ISAPI dll (as each is treated as a different site, underneath the application pool) Now, this setup works well for me, everything is on the same server I can roll out updates and make backups easily enough. Now down to my question… However, the server only has a certain amount of scaling, let’s say I have maxed out ram/cpu and I now have a new customer, let’s say customer3. I would now have to purchase a new VM server to accommodate customer3. I would like to be able to have customer3's url of www.uniguiapp.com/customer3 , eventhough it is running on a different server. (with a different IP of course) I want to know if this is possible, and how to achieve it. Currently I have my server IP mapped to the domain name using a single A record, then my site in IIS maps to the correct directory. Can I achieve what I need by have another A record on the new server of www.uniguiapp.com/customer3 ? Apologies for the long post, and thanks for reading. Any advice is welcome.
  9. Boa tarde, eu estou desenvolvendo uma aplicação com hospedagem no IIS, e neste como todos, gero relatorios em PDF usando o FastReports. Uso esse código para gerar o PDF. NomeRPT.PrepareReport(True); ArqPDF := NomeRelPDF+'_'+FormatDateTime('ddmmyyyy_hhmmss.zzz',Now)+'.pdf'; PDFExport.FileName := ArqPDF; PDFExport.DefaultPath := UniServerModule.LocalCachePath; PDFExport.ShowDialog := false; PDFExport.ShowProgress := False; NomeRPT.Export(Self.PDFExport); NomeRPT.PreviewPages.SaveToFile(ArqPDF); frmRelatorios_Movimento.UniPDFFrame1.PdfURL := UniServerModule.LocalCacheURL + ArqPDF; // Displayed on UniURLFrame frmRelatorios_Movimento.ShowModal; Ele está gerando normalmente o arquivo na Cache do Servidor (pasta criada pelo Unigui na raíz da aplicação), porém, ele cria o mesmo arquivo dentro da C:\Windows\SysWOW64, só que isso vai enchendo a pasta de sistemas com arquivos PDF e eu não consigo encontrar onde é o problema que o mesmo salva uma copia do arquivo na pasta de sistema. Alguém já viu algo parecido com isso?
  10. Hi Guys, Hoping someone can give me a little bit of help with a application crash/timeout using IIS. The below works fine using stand-alone deployment - this is only an issue in my production IIS environment. ekkkk (please help) This is reproducible every time I do the same operation - which is using a component to export a dataset to excel (the component is EMS Advanced data export) All I do is call execute on this component to take what I have in the dataset (5 records) and output it to excel. I have one modal form - with the export component and a grid - all code is local to the form, apart from the dataset which is located on a datamodule. This application has EnableSynchronousOperations := true; I am using SSL https 1.All records are outputted correctly to the excel file (xlsx) and the file exist where I expect on the file system. It opens perfectly well. 2.As soon as the .execute method is called, I immediately call UniSession.SendFile(_FilePath, ExtractFileName(_FilePath)); This also excutes and allows me to "download" the xlsx and the contents is fine. 3.It is at his point the application becomes unresponsive, I call modalresult := mrok on the form and nothing happens. This is the error I am getting from windows event viewer - A worker process '3856' serving application pool 'AppPool' failed to stop a listener channel for protocol 'http' in the allotted time. The data field contains the error number. Event ID = 5138 (strange as I am using https, not http) I can also see this event A process serving application pool 'AppPool' exceeded time limits during shut down. The process id was '3856'. Event ID = 5013 UniGUI log shows nothing It seems to just crash/timeout the session/instance of the application, not the server - once i hit refresh I can log back into the application. (obviously the issue will occur again if I try to export) Here are my IIS settings (should be exactly the same as per instructions from the deployment guide) https://www.dropbox.com/s/t51rlbogxd5cxkk/iis.png?dl=0 Delphi 10.1 Berlin Unigui Complete 1.0.0.1420 Thanks for any help, Dan.
  11. Hi All, I use apple-touch-icon and apple-touch-icon-precomposed to be able to get a custom icon when adding my app to the homescreen on an iOS device. This then allows the app to open from the home screen with a customer icon, that I have specified on the server. All is fine when I use the UniGUI standalone server - it just pulls through as expected. Now, when I deploy using IIS - the icon is not pulled through and the icon is the default (a screen shot of the webpage) This is pretty important for me, as deployment requires that the web app, looks and feels like a 'native' iOS app, and part of that is having the correct icon on the homescreen. Any ideas? Do I need to do anything additional in IIS? Regards, Dan.
  12. Hi Fashard, I have this problem a long time, but this latest version is more frequent. fenix14.dll: 00002594: 08:19:26 [177.10.209.183]:UniErrorException : Event:click, Object: O1547 not found in session list. It could be timed out, refresh page and try again : Addr: $00000000 fenix14.dll: 00002124: 08:20:00 []:>--------------------------------------------------------------< fenix14.dll: 00002124: 08:20:00 []:Starting Server. Module Handle: 0000000002710000 fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Server First Init. fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Erasing Cache Folder... fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Cache Folder Erased. <3158> Files deleted. fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:HTTP Server not Started! fenix14.dll: 00002124: 08:20:00 []:Server Started. Module Handle: 0000000002710000 fenix14.dll: 00001AC4: 10:28:37 [177.43.138.249]:UniErrorException : Event:click, Object: O3BD9 not found in session list. It could be timed out, refresh page and try again : Addr: $00000000 fenix14.dll: 00002F90: 10:29:41 []:>--------------------------------------------------------------< fenix14.dll: 00002F90: 10:29:41 []:Starting Server. Module Handle: 0000000002280000 fenix14.dll: 00002F90: 10:29:41 [TUniServerModule]:Server First Init. fenix14.dll: 00002F90: 10:29:41 [TUniServerModule]:Erasing Cache Folder... fenix14.dll: 00002F90: 10:29:42 [TUniServerModule]:Cache Folder Erased. <4892> Files deleted. fenix14.dll: 00002F90: 10:29:42 [TUniServerModule]:HTTP Server not Started! fenix14.dll: 00002F90: 10:29:42 []:Server Started. Module Handle: 0000000002280000 fenix14.dll: 00002E04: 11:18:34 [HttpExtensionProc[191.177.186.15]]:EUniSessionException : Sessão expirada ou tempo de sessão esgotado. : Addr: $026A5FE3 fenix14.dll: 00001164: 11:26:21 []:>--------------------------------------------------------------< fenix14.dll: 00001164: 11:26:21 []:Starting Server. Module Handle: 0000000002910000 fenix14.dll: 00001164: 11:26:21 [TUniServerModule]:Server First Init. fenix14.dll: 00001164: 11:26:21 [TUniServerModule]:Erasing Cache Folder... fenix14.dll: 00001164: 11:26:22 [TUniServerModule]:Cache Folder Erased. <4228> Files deleted. fenix14.dll: 00001164: 11:26:22 [TUniServerModule]:HTTP Server not Started! fenix14.dll: 00001164: 11:26:22 []:Server Started. Module Handle: 0000000002910000 fenix14.dll: 00002F2C: 12:38:34 []:>--------------------------------------------------------------< fenix14.dll: 00002F2C: 12:38:34 []:Starting Server. Module Handle: 00000000027E0000 fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Server First Init. fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Erasing Cache Folder... fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Cache Folder Erased. <1278> Files deleted. fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:HTTP Server not Started! fenix14.dll: 00002F2C: 12:38:35 []:Server Started. Module Handle: 00000000027E0000 fenix14.dll: 00002E38: 13:37:08 [191.177.186.15]:UniErrorException : Event:keydown, Object: O17CB not found in session list. It could be timed out, refresh page and try again : Addr: $00000000 fenix14.dll: 00002E64: 13:40:43 []:>--------------------------------------------------------------< fenix14.dll: 00002E64: 13:40:43 []:Starting Server. Module Handle: 0000000002710000 fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Server First Init. fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Erasing Cache Folder... fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Cache Folder Erased. <3741> Files deleted. fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:HTTP Server not Started! fenix14.dll: 00002E64: 13:40:43 []:Server Started. Module Handle: 0000000002710000 Log error IIS Faulting application name: w3wp.exe, version: 8.5.9600.16384, time stamp: 0x52157ba0 Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0x00000000 Faulting process id: 0x2504 Faulting application start time: 0x01d1971adce7901f Faulting application path: C:\Windows\SysWOW64\inetsrv\w3wp.exe Faulting module path: unknown Report Id: 05081776-0316-11e6-80bd-00259047b90c Faulting package full name: Faulting package-relative application ID: Best regards
  13. Hello, I've created Standalone Application at the start and then I tranformed it into a ISAPI module (comment line for GUI in project source) witch I've put on IIS 7.5. When I call .dll first form shows as it should, but when I click some data on DBGrid it should open new form with details of that record. In standalone app works fine, but as ISAPI modulu it doesn't. I've checked log and there is this. Workflow: 00001E24: 07:23:21 []:-------------------------------------------------------------- Workflow: 00001E24: 07:23:21 []:Starting Server. Module Handle: 00000000022A0000 Workflow.dll: 00001E24: 07:23:21 [TUniServerModule]:Server First Init. Workflow.dll: 00001E24: 07:23:21 [TUniServerModule]:Erasing Cache Folder... Workflow.dll: 00001E24: 07:23:21 [TUniServerModule]:Cache Folder Erased. <0> Files deleted. Workflow.dll: 00001E24: 07:23:21 [TUniServerModule]:HTTP Server Started. Workflow: 00001E24: 07:23:21 []:Server Started. Module Handle: 00000000022A0000 Does this error tell you enything what I am doing wrong? Best regards.
  14. Hello UniGuys, I have some questions about the configuration of a unigui isapi modul in IIS (7.5, or 8.0). in the log of my deployed dll i find entries like this: adm: 00002FD0: 10:25:13 [HttpExtensionProc[31.25.121.236]]:EUniSessionException : Invalid session or session Timeout. : Addr: $01EFDC44 adm: 00000DFC: 10:36:41 [HttpExtensionProc[31.25.121.236]]:EUniSessionException : Invalid session or session Timeout. : Addr: $01EFDC44 i set my Application pool in IIS with following settings (Process Model): idle Timeout (minutes) -> 2 Idle Timeout Action -> Terminate so after 2 minutes nobody do a request to this process it will be terminated. In live envirement this will be of course a longer period . Recycling Condition - Fixed Intervalls: Regular time intervals in minutes -> 480 So all 480 Minutes all processes of this application pool gets reloaded. i set my Servermodule Settings to following: SessionTimeout -> 600000 soRestartSessionOnTimeout -> true I assume that if a Worker process on the IIS get terminated, that will also kill the unigui session. if a user do some action after the worker process is terminated, a new worker process is created who doesn't now anything about the unigui session. Right? Whats about configuring the application pool as a webgarden? That means that the isapi module is loaded in serveral worker processes parallel and the IIS decides which process is used for a request. So you see, i am a bit confused about the rigth way to deploy a unigui isapi dll. And i definitly know less about the Session model in unigui. Maybe somebody can me explain me how i should go to get optimal settings for unigui session and for IIS worker process?
  15. out of system resources has anyone had this type of message in your application? this error started appearing for my clients, this is happening when I have more than 30 clients connected simultaneously. after presenting this error all of my clients have the same problem. to resolve I have to recycle the IIS process pool, where I have to knock down all that are connected. anyone have any idea what can be?
×
×
  • Create New...