Jump to content

Q: Different ExtJSversions on same server?


Recommended Posts



I created a new application based on the latest uniGui version and ExtJSversion

On our server we have applications running with ExtJSversion  and build with

a earlies version of uniGui


When i want to run the new application i got only the 'Loading' screen. The loading mechanisme

in 4.2.2. is different from previous version.


Is it possible to put 2 different ExtJSVersions on the same server and point the old

application to version and the new application to ?


Regards Peter

Link to comment
Share on other sites

Hi mierlp,

I have two apps running in different version in a same server.

You can compile one of your project with server module

option ExtRoot: [ext]\ and the other one with: ext-\

In the second option you'll have to copy two folders beside your app: ext- and uni- (or same version you're using)

Or, finally, compile each one in the second way.

Hope this helps, regards.

Link to comment
Share on other sites



For some reason i stuck with my new application on a loading issue.


What did i do:

- I have a database application (as .dll) build with a earlier version of uniGui and ExtJS, this WORKS on our server

- make a copy of this application, customiced it and run it as a stand-alone applicaton running on MY DEVELOP PC...this works

- installed the runtime version/copy ext. directory to the server next to the existing version

- both applications are using a config.ini file into there application/dll dirctory. This config.ini contains a setting for the ext\ map. In old application
  this is empty so it point to the default installed ext\ map....everything works
- for the new application i set this parameter in his own config.ini to ext4.2.2.1144\

- when starting the new application it only displays the loading message

- when i copy a old application(which uses the older verions of extjs) to this dierctory this application works!


I can't figure out why this new version 'WORKS on my developer computer and is  'NOT WORKING' on our server
and only displaying the 'Loading' message.


I have several applications working but can't get the new one working and don't know where to search. I've tried it

as a dll and standalone server on our server but both the same result. All other applications are .dll with ISS 7


Teamviewer access is possible to my developer pc or server



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...