Jump to content

One Server, Two applications, one calls the other !?


Recommended Posts

On the same server :

- UniApplication 1  (Port 8077)    with  Unigui  Build 1523  / 64 bit

- UniApplication 2  (Port 8078)    with  Unigui  Build 1531  / 64 bit

Run  As Service (HyperServer)    both

Result:  on the browser

192.168.1.10:8077   -->  display  UniApplication 2

192.168.1.10:8078   -->  display  UniApplication 1

Why ?

I have to refresh twice or more the browser (F5) to get the good behavior  (even with Delete data Navigations on browser options).

@Farshad, did i forget something ?

Regards...

______________

Delphi 10.3.3 Pro -  Unigui 1531

Link to post
Share on other sites
9 hours ago, donlego said:

change the hyperserver config

app1

[http_transport]
start_port=16384

 

app2

[http_transport]
start_port=36384

Thanks again.

Confirmed, that works fine.

Link to post
Share on other sites

@FmSoft Team,

I think this topic is very important that it deserves to be mentioned in the documentation.
I realized that a lot of topics have already been posted on this subject. This proves that it is really not obvious!

Please update the doc.

Thx

  • Like 1
Link to post
Share on other sites
  • 4 months later...
On 6/4/2020 at 7:13 PM, Abaksoft said:

@FmSoft Team,

I think this topic is very important that it deserves to be mentioned in the documentation.
I realized that a lot of topics have already been posted on this subject. This proves that it is really not obvious!

Please update the doc.

Thx

Hi 

thank you both

I totally agree that this is very important information and must be added to the documentation, I have wasted many hours trying to find out why was not working 

Link to post
Share on other sites
On 6/4/2020 at 3:20 AM, Abaksoft said:

On the same server :

- UniApplication 1  (Port 8077)    with  Unigui  Build 1523  / 64 bit

- UniApplication 2  (Port 8078)    with  Unigui  Build 1531  / 64 bit

Run  As Service (HyperServer)    both

Result:  on the browser

192.168.1.10:8077   -->  display  UniApplication 2

192.168.1.10:8078   -->  display  UniApplication 1

Why ?

I have to refresh twice or more the browser (F5) to get the good behavior  (even with Delete data Navigations on browser options).

@Farshad, did i forget something ?

Regards...

______________

Delphi 10.3.3 Pro -  Unigui 1531

First,I Think the two UniApplication should be the same version.

Second,You should assign different startport

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...