Jump to content
uniGUI Discussion Forums
herculanojs

Url params bug mobile

Recommended Posts

'm having trouble in the application when running mobile. In the onhow of the mobile main form I am checking the parameters that should be passed by the webbrowser, however they are always zeroed. This does not occur when the operation is not mobile.
That is, if I remove the unmmain of the project, the parameters arrive normally, but if add to unmmain does not arrive parameters.

 
Something we should enable or disable?
Is it not possible to pass parameters to mobile application?
 
send webbrowser
 
 
(ok) functional
 
1) MainForm 

procedure TMainForm.UniFormShow(Sender: TObject);
var i:integer;
begin
     if UniApplication.Parameters.Count > 0 then
     begin
          for I := 0 to UniApplication.Parameters.Count-1 do
          begin
               UniMemo1.Lines.Add(UniApplication.Parameters.Names);
          end;
     end;
end;
 
(no) functional

2) procedure TMainmForm.UnimFormShow(Sender: TObject);

var i:integer;
begin
     if UniApplication.Parameters.Count > 0 then
     begin
          for I := 0 to UniApplication.Parameters.Count-1 do
          begin
               UniMemo1.Lines.Add(UniApplication.Parameters.Names);
          end;
     end;
 
end;

unigui webbrowser.rar

Share this post


Link to post
Share on other sites

If MainmForm is removed so that it does not exist in the project, the parameters normally arrive in the MainForm.

Share this post


Link to post
Share on other sites

This is for a desktop app

How should it be passed to mobile, for example?
I'm calling the unigui application from within a webbrowser on fmx

Share this post


Link to post
Share on other sites

URL Parametres for mobile applications should be something like this:

http://localhost:8077/m/?button=BB&edit=AA

Share this post


Link to post
Share on other sites

×