Jump to content


Photo

how to hiding Dll extension in the url in IIS?


  • Please log in to reply
19 replies to this topic

#1 alf

alf

    Member

  • uniGUI Subscriber
  • PipPip
  • 42 posts

Posted 27 April 2014 - 12:32 PM

Hello all:

 

How to hiding  Dll extension in the url in IIS?

 

 

Thanks

 


  • 0

#2 brunotoira

brunotoira

    Member

  • Members
  • PipPip
  • 37 posts

Posted 28 April 2014 - 02:36 PM

+1


  • 0

#3 hootchi

hootchi

    Member

  • Members
  • PipPip
  • 15 posts

Posted 30 April 2014 - 08:23 AM

How to hiding  Dll extension in the url in IIS?

 

I alway set dll as Default Document on IIS and it works well :)


  • 0

Windows 8.1 Pro x64 | XE7 | uniGUI 0.98.0.1114


#4 ywlfff

ywlfff

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 13 April 2016 - 05:40 AM

I alway set dll as Default Document on IIS and it works well :)

Why didn't I do this effect


  • 0

#5 Yuriy O.

Yuriy O.

    Active Member

  • uniGUI Subscriber
  • PipPipPip
  • 50 posts

Posted 13 April 2016 - 02:11 PM

Try to create simple html and insert frame with your dll path


<head>
<script>
function getInlineFrame()
{
document.getElementById('InlineFrame1').src=s;
}
</script>
</head>
 
<body onload="getInlineFrame();">
 
<div id="Layer1" style="position:fixed;left:0px;top:0px;right:0px;bottom:0px;z-index:2;" title="">
<iframe name="InlineFrame1" id="InlineFrame1" style="position:absolute;left:0%;top:0%;width:100%;height:100%;z-index:0;" src="about:blank" frameborder="0">Your browser does not support inline frames or is currently configured not to display inline frames.</iframe>
</div>
 
</body>

  • 0

#6 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 13 April 2016 - 07:36 PM

Use URL Rewrite on IIS.


  • 0

#7 delphidude

delphidude

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 141 posts
  • LocationNorway

Posted 05 January 2017 - 12:51 AM

Just discovered how to do it on apache, just use DirectoryIndex

 

<Directory "C:/mydlldir/">
    Options FollowSymLinks ExecCGI
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex mydll.dll
</Directory>
Alias /myapp "C:/mydlldir"

 

Navigating to http://myserver.com/myapp will load the dll, hiding the extension in the url.

 

You should be able to set the directory index file specifically in IIS too, of course.


  • 0

#8 irwan

irwan

    Active Member

  • uniGUI Subscriber
  • PipPipPip
  • 65 posts

Posted 26 May 2017 - 11:25 PM

Just discovered how to do it on apache, just use DirectoryIndex

 

<Directory "C:/mydlldir/">
    Options FollowSymLinks ExecCGI
    AllowOverride None
    Order allow,deny
    Allow from all
    DirectoryIndex mydll.dll
</Directory>
Alias /myapp "C:/mydlldir"

 

Navigating to http://myserver.com/myapp will load the dll, hiding the extension in the url.

 

You should be able to set the directory index file specifically in IIS too, of course.

 

 

i use this but every logout to login form again, original .dll will appear in url link so i use this

<html>
	<head>
	</head>
	<frameset rows="100%,*" border="0">
	  <frame src="http://domain.com/your.dll" frameborder="0"></frame>
	  <frame frameborder="0" noresize=""></frame>
	</frameset>
</html>

  • 0

#9 Ronny Encarnacion

Ronny Encarnacion

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 488 posts

Posted 29 May 2017 - 12:13 PM

You can add a DLL as  a default document in Your Virtual Folder or Application in the IIS then You can hide de DLL http://youraddress/


  • 0

Ronny Encarnacion


#10 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 29 May 2017 - 12:23 PM

Imho, the simpliest and easiest way is by using "URL Rewrite" on IIS.
  • 0

#11 daveelt

daveelt

    Member

  • uniGUI Subscriber
  • PipPip
  • 10 posts

Posted 08 June 2017 - 12:26 AM

Can anyone tell me if they got URL rewrite working.  I have tried all alterations and have been unable to get it to rewrite for the DLL.

 

Any help would be appreciated.


  • 0

#12 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 08 June 2017 - 07:40 AM

I did
  • 0

#13 Marlon

Marlon

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 305 posts
  • LocationNova Mutum - MT - Brasil

Posted 08 June 2017 - 12:16 PM

This is very simple if it is IIS:

 

iis1.jpg

 

ii2.jpg

 

or page 6

 

https://store.falcon...SAPI_Module.pdf


  • 0

#14 daveelt

daveelt

    Member

  • uniGUI Subscriber
  • PipPip
  • 10 posts

Posted 08 June 2017 - 03:12 PM

I can make it the default document, but don't necessarily want it to be the default.  I am trying to get URL rewrite to work and while I can get test the matching successfully, the rewrite does not happen when coming into the server.

 

Can someone that has gotten URL rewrite to work give me their process?  I must be missing something somewhere.

 

Thanks


  • 0

#15 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 08 June 2017 - 03:33 PM

Could you please tell what is your original URL, and how do you want it should like ?
  • 0

#16 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 08 June 2017 - 03:33 PM

Could you please tell what is your original URL, and how do you want it should like ?
  • 0

#17 daveelt

daveelt

    Member

  • uniGUI Subscriber
  • PipPip
  • 10 posts

Posted 08 June 2017 - 04:42 PM

my original is xx.xxxxx.com/XXXXX.dll  and I want xx.xxxxx.com/xxxxx to be what the user would type to reach it.


  • 0

#18 ZigZig

ZigZig

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 334 posts

Posted 08 June 2017 - 04:56 PM

Hi,

 

Click on "Add a rule", then fill the pop-up window as shown in this screenshot (it is the French-translated version of URLRewrite because my Windows Server is on a French server, but you'll find the same fields in the same place in English).

Don't forget to check the two checkboxes in the bottom of the screen.

 

More d├ętails here: https://docs.microso...-rewrite-module

 

 

 

Attached Files


  • 0

#19 daveelt

daveelt

    Member

  • uniGUI Subscriber
  • PipPip
  • 10 posts

Posted 08 June 2017 - 08:17 PM

Thank you for your help.

 

Unfortunately,  I tried that way and it will not do the rewrite. The error shows it cannot find the file https://xx.xxxxx.com/xxxxx

 

I am thinking there must be some setting in the IIS server preventing the rewrite.  Just can't find it.


  • 0

#20 daveelt

daveelt

    Member

  • uniGUI Subscriber
  • PipPip
  • 10 posts

Posted 08 June 2017 - 09:21 PM

I got it.  Turns our the IIS URL Rewrite module did not do a clean install.  Running a repair fixed it right up.

 

Thanks


  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users