Jump to content

build 943


Mediv
 Share

Recommended Posts

Hi Farshad.

In the build is 927 for the installation

Query Component -> Fields Editor -> DisplayFormat = 0.00, a value of zero in the grid

displayed as 0.00, after upgrading to build 943 had to remove the formatting so that the value of 1153.23 was displayed, as 1.153,

but the value of zero is now displayed as 0, and wanted to be like 0.00

How can I do this?

Thank you.

Link to comment
Share on other sites

Can you provide following info:

 

DecimalSeparator

ThousandsSeparator

DisplayFormat

Your Field data

Value displayed in the grid.

 

Settings on the computer - 12 pic

DisplayFormat empty - 11,13 pic

DisplayFormat not empty - 14,15 pic

 

 

If pointing DisplayFormat, it is rounding the data.

post-475-0-88235800-1333032034_thumb.png

post-475-0-05642300-1333032127_thumb.png

post-475-0-36929800-1333032134_thumb.png

post-475-0-82408900-1333032140_thumb.png

post-475-0-35237700-1333032150_thumb.png

Link to comment
Share on other sites

In my PC it behaves like this:

 

DecimalSeparator = ,

ThousandSeparator= .

DisplayFormat = Empty , Value diplayed as 1.23 (expected behavior)

DisplayFormat = 0.00 , Value diplayed as 1,23

FieldType = TFloatField

 

Can you send a simple test?

I'll try to do it on your example DBLookup, but only tomorrow.

Link to comment
Share on other sites

Make sure you have the latest build 0.88.1.943 installed.

 

You can use GridEditors demo.

 

I took your demo DBLookup.

I put DisplayFormat = 0.00 for the field and was rounding TaxRate data, try, I can send your project If you are usin needed.

post-475-0-88213400-1333034604_thumb.png

post-475-0-18991700-1333034610_thumb.png

Link to comment
Share on other sites

I can't reproduce in any of my PCs.

 

Please re-check your uniGUI version.

build 943.

 

Well, I decided to have a problem changing the settings on my computer, the main thing that works as expected.

Thanks for your help.

post-475-0-52267900-1333101047_thumb.png

Link to comment
Share on other sites

Hello !!!

 

I need to know something, and I need a help from you.

 

I have a field "MontoAPrestar" of type TBCDField (Money in the DB), and all the time in the user interface appears an error when user type numbers in the form's field using comma.

 

OS: Windows XP

Delphi: 2009

Browser: Chrome

UNIGUI: 941

 

Is there something I'm missing? This error comes from UNIGUI, from Delphi, from Browser???

 

Note: I saw this entry in the "what's new" of .943 build

 

- 0001270: UniDBGrid: Float/number field ignores decimal/thousand separators.

 

It concern to my problem too or not?

 

post-125-0-32120200-1333109440_thumb.pngpost-125-0-07845900-1333109451_thumb.pngpost-125-0-96872700-1333109465_thumb.png

Link to comment
Share on other sites

This a Delphi error. While editing comma should not be used because uniGUI doesn't support EditFormat yet.

Thanks, I'll keep in mind. This error only in delphi 2007 or xe2 will also?

In the near future we plan to compile the project under delphi xe2.

Link to comment
Share on other sites

  • Administrators

Thanks, I'll keep in mind. This error only in delphi 2007 or xe2 will also?

In the near future we plan to compile the project under delphi xe2.

 

You can use Comma in display format with no problem. When entering float data in cell we need to use DOT as decimal separator and no comma.

 

It is same for all Delphi versions.

Link to comment
Share on other sites

  • 2 years later...
Query Run Time Field DisplayFormat

 

Unit uses add

 

Data.DB,

 

 

procedure Form1.UniButton1Click(Sender: TObject);

begin

 

with Query1 do

 begin

   Close;

   SQL.Clear;

   SQl.Add('Select * from Table');

   open;

 end;

 

  TFloatField(Query1.FieldByName('FieldName')).DisplayFormat :='###,###';

 

   if not Query1.IsEmpty then

   begin

    UniDBGrid1.DataSource := DataSource1;

   end

   else

   begin

    UniDBGrid1.DataSource := nil;

   end;

  

 

end;

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...