Jump to content

Download doesn't work - IPAD


vbdavie
 Share

Recommended Posts

I'm using the Full Demo build 1205.

I have an IPAD with Safari and Chrome installed.

When I click on the "Download & Upload" then "Advanced Download", I can click on any of the 4 download buttons, but nothing happens. I don't see a visual clue that anythnig has happened.

 

Is there an issue on the IPAD where we can't do the download function? I didn't try with FireFox since it's NOT my IPAD. So, I could only try with Safari and Chrome.

 

Anybody else experience this?

 

Davie

Link to comment
Share on other sites

Not sure what you mean by that.

iOS doesn't support downloading files to system storage. That's an iOS limitation/restriction.

 

So, you are saying that a statement like....     

UniSession.SendFile(UniServerModule.LocalCachePath +fn, fn);
 

Will essentially do NOTHING? If so, then very interesting. I guess you would have to provide a clickable link or button on the web page for the user to get a file?
 

Davie

Link to comment
Share on other sites

  • Administrators

I guess you would have to provide a clickable link or button on the web page for the user to get a file?

 

 

Problem here is that you can not download a file with a browser on iOS device. It also highly depends on file type.

 

I haven't looked deeply into this, but I can say that our regular download method which works on all other browsers doesn't work on iOS.

Maybe there are some tricks or workarounds to download and show specific files such as a PDF doc.

Link to comment
Share on other sites

I have no problem viewing PDF files on my IPAD.

 

I USED to have probems, especially with FastReport PDFs, but now that is solved :)

 

I read at least 30 to 40 threads on the subject and was very disappointed. I had 2 ways in which I was going to solve it, but didn't like either of them. It was kind of like brute force or hard coding. Hate them. BUT, I found a post from a guy that was laughing at all the people claiming that FastReports produced wrong PDFs and that they needed to be PDF/A and so on. And he said "Just change this ONE line of code in the PDFExport pas file.

 

So, I did. and WOWOWOWOWOW. It fixed it so that all my PDFs could display on the IPAD and the text and graphics all displayed perfectly. Amazing. So, I am going to make a forum post and shows the simple trick.

 

I know that FastReports is NOT your product, but I feel that a lot of people use it and that newbies to this web framework may feel that their reports not displaying properly is a bug in your software and will ask you why the pdfs don't show :)

 

So, by me posting the solution, it's a win win again.

 

Does that make sense?

 

Thanks

DAvie

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...