Jump to content

IIS 10 to deploy ISAP DLL


Recommended Posts

I am trying to deploy my app with  ISAPI DLL. Using IIS 10

I followed all the steps of this link up to the last line without any problem

Developer's Guide > Deployment > ISAPI Module > IIS 7 and Later (unigui.com)

http://www.unigui.com/doc/online_help/iis_7_0.htm

The main paths I used are in the figure attached.

MY DOUBTS ARE

1)      Is it necessary to rewrite or add something to the Windows host file? Or this is automatically made when I set IIS as above ? I think it is not automatic because seems that nothing was added automatically. The contents of my file, after configuring all the steps of the link above

2)      After the steps above is it necessary to go in IIS to add any virtual directory?

3)       Having in mind the paths written in the figure , what should I type in the browser to view the webswd.dll contents (was build  successfully) ? Something like http://localhost/webswd  ?

-----------end of text ----------------------------

HOSTS file                                     # ( no mention to  webswd paths

# Copyright (c) 1993-2009 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

127.0.0.1                                                             activate.adobe.com

127.0.0.1                                                             practivate.adobe.com

127.0.0.1                                                             ereg.adobe.com

127.0.0.1                                                             activate.wip3.adobe.com

127.0.0.1                                                             wip3.adobe.com

127.0.0.1                                                             3dns-3.adobe.com

127.0.0.1                                                             wwis-dubc1-vip60.adobe.com

IIS10sergio.png

Link to post
Share on other sites

I think it is working now at least in the localhost  > Really using IIS is not difficult as was difficult with APACHE

I did not need to go manually to modify the hosts file 

Seems that my problem was just to set the "Restrictions ISAPI CGI" (  like here https://docs.microsoft.com/pt-BR/troubleshoot/iis/http-error-402-webpage   )

I suggest to include this information in the  link http://unigui.com/doc/online_help/iis_7_0.htm

Link to post
Share on other sites

I suggest to Unigui team to include the following in the “Deployment Area”

So, just to resume what to do to deploy a ISAI DLL code with IIS 10 do the following:

Suppose that the physical path of  the dll is  C:\webswd\webswd.dll (see the figure in this post)

a)       Create the DLL in Delphi IDE “commenting the first line of the code”.

b)      Do the settings of IIS 10 using EXACTLY the steps of http://unigui.com/doc/online_help/iis_7_0.htm

c)       After the last step go to the IIS in the area “RESTRICTIONS of CGI / ISAPI doing the following  https://docs.microsoft.com/pt-BR/troubleshoot/iis/http-error-402-webpage    which translated means

Configure the constraint on the ISAPI and CGI Restrictions page to allow the requested ISAPI resource or the requested CGI resource. Follow these steps to resolve this issue: Select Start, type    Inetmgr    in the Start Search box, and then select    Inetmgr    from the Programs list. If you are asked to request an administrator password or confirmation, enter the password or select Continue. Locate the level you want to configure. In the Features view, double-click ISAPI and CGI restrictions. Right-click the constraint that restricts the requested ISAPI resource or requested CGI resource and select Allow.(Enable)

d)      After the last step it should work if you type in the browser,    http://localhost/webswd/webswd.dll

e)      If you wish to type a shorter name 

Enter IIS and select webswd and, in the middle of the pag,e select Standard Document Click on it and "Open Resource" will appear on the right Click on it and then Add will appear. Click  Add and type the name of DL  Lwebswd.dll

From here you can just type  http://localhost/webswd

  • Like 1
Link to post
Share on other sites
×
×
  • Create New...