Jump to content
uniGUI Discussion Forums
Sign in to follow this  
Kiener

1422: Error compiling uniGUI25dcl.dpk

Recommended Posts

[dcc32 Fataler Fehler] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities wurde mit einer unterschiedlichen Version von ToolsAPI.IOTASourceEditor compiliert

 

Tokyo 10.2 Update 2

Share this post


Link to post
Share on other sites

Same with version 1404.

 

Must be a problem of Rad Studio 10.2 Update 2.

 

Any ideas?

Share this post


Link to post
Share on other sites

Thank you for your reply. I realized that this was the problem. The question is whether the problem can be solved in version 10.2.2 or whether a new uniGUI compilation will appear.
 

Share this post


Link to post
Share on other sites

Thank you for your reply. I realized that this was the problem. The question is whether the problem can be solved in version 10.2.2 or whether a new uniGUI compilation will appear.

 

Marco Cantu's blog indicates this is an Embarcadero/Delphi 10.2.2 problem, not a Unigui problem. Other products are being affected besides Unigui.

 

I think we need to wait for Embarcadero to release a hotfix to fix the problem across the board for all venders. And it sounds like we might see it sometime next week...

 

That's how I read the situation anyway =)

 

Sent from my SM-P900 using Tapatalk

Share this post


Link to post
Share on other sites

I also read about it on Embarcadero forums. The problem is bigger. We are waiting. Thank you for your attention to this problem.
 

Share this post


Link to post
Share on other sites

I also read about it on Embarcadero forums. The problem is bigger. We are waiting. Thank you for your attention to this problem.

 

 

Unfortunately, even build 2004 did not fix the error: ...was compiled with a different version of ToolsAPI.IOTASourceEditor

Share this post


Link to post
Share on other sites

The problem is with al lot more third part components then only uniGUI.

I upgrade to Tokyo 10.2.2 and have problems with DevArt myDAC, EHLib, ImageEN

 

There's a fix from december 17 which resolves some issue, but not all.

Problems with ImageEN en EHLib are still there. Because of a clean install

of my computer i didn't had the time to install uniGui.. 

Share this post


Link to post
Share on other sites
Hello,
 
How I can to install on Tokyo 10.2 ( not updated 1 or 2 ) .... 
 
I download last version 1023 and I have same error: [dcc32 Fatal Error] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities was compiled with a different version of ToolsAPI.IOTASourceEditor
 
I need to download a old version of UniGUI ??
 
Now I can't update the Tokyo 10.2.2 ... for many components update

 

please

Antonello

Share this post


Link to post
Share on other sites

Hi,

 

 

Hello,
 
How I can to install on Tokyo 10.2 ( not updated 1 or 2 ) .... 
 
I download last version 1023 and I have same error: [dcc32 Fatal Error] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities was compiled with a different version of ToolsAPI.IOTASourceEditor
 
I need to download a old version of UniGUI ??
 
Now I can't update the Tokyo 10.2.2 ... for many components update

 

please

Antonello

 

 

If I understand you correctly:

http://forums.unigui.com/index.php?/topic/8937-unigui-100/page-7&do=findComment&comment=50422

Share this post


Link to post
Share on other sites

I see a lot of talk but no solution - where do we stand on the uniGUI 1-00-02 Tokyo 10.2.2 Install Issue ?

 

Does anyone have a work around ?

 

Tokyo 10.2.2
C:\Program Files (x86)\FMSoft\Framework\uniGUI\uniGUI_D10_2_Tokyo_PlusGroup.groupproj
 
ERRORS
package uniGUI25dcl;
uniNativeImageListDialog in 'uniNativeImageListDialog.pas' {ImgListNativeForm};
[dcc32 Fatal Error] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities was compiled with a different version of ToolsAPI.IOTASourceEditor
 
package uniGUI25dcl;
[dcc32 Fatal Error] uniGUI25mdcl.dpk(33): E2202 Required package 'uniGUI25dcl' not found

Share this post


Link to post
Share on other sites

Our build 1423 is DCU compatible with 10.2.2.

Hi, I've tried the 1423 build (Trial) today, still the same error at the installation

[dcc32 Fatal Error] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities was compiled with a different version of ToolsAPI.IOTASourceEditor
I'm using Delphi 10.2.2 build 2004
Thank you.

Share this post


Link to post
Share on other sites

 

Hi, I've tried the 1423 build (Trial) today, still the same error at the installation

[dcc32 Fatal Error] uniGUI25dcl.dpk(73): F2051 Unit ExpertUtilities was compiled with a different version of ToolsAPI.IOTASourceEditor
I'm using Delphi 10.2.2 build 2004
Thank you.

 

 

Hi, where from did you download build 1423?

Share this post


Link to post
Share on other sites

Hi, where from did you download build 1423?

Sorry my bad, it's only 1421 (FMSoft_uniGUI_Complete_Professional_1.0.0.1421_Trial.exe)

Share this post


Link to post
Share on other sites

The installers I used (from my portal):-

 

xxx_1.0.2.1426.exe

 

Produced the problems I mentioned earlier.

 

My Delphi Version:-

 

Embarcadero® RAD Studio 10.2 Version 25.0.29039.2004

 

Can we please have a solution ASAP - Thanks.

Share this post


Link to post
Share on other sites

One would assume FMSoft_uniGUI_Complete_Professional_1.0.2.1426 (the only installer on my portal) is later than 1423 ?

 

I am not making up stories, when I say it will not compile - It Will Not Compile !

 

Farshad, do you want to do a TeamViewer Remote Control to see for your self ? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×