Jump to content
uniGUI Discussion Forums
RobYost

Autofill how to turn off

Recommended Posts

Is there a way to turn off autofill (or maybe called autocomplete) in the application?

 

When filling in the  form the browser  prompts to autofil the Edit fields on the screen.  The information presented to autofill would never be the correct information, so I would like to turn it off in my program.

 

 

It looks like it can be added to the form property, but I don't know how.

 

<form method="post" action="/form" autocomplete="off">

Share this post


Link to post
Share on other sites

In Chrome (and probably the other browsers as well) 

go to Settings->Advanced->Passwords and forms

 

There you will see Autofill settings.

 

In there you will see addresses:

with a bunch of addresses (and credit cards), you have filled out on other web pages

 

If you are on a web page that has what chrome thinks is an address it will prompt to put in one the saved addresses.

 

In my case these addresses will never be correct, so I would like to NOT have Chrome prompt with the option to fill in the address fields.

 

From what I found out on the internet if you have a form on a web page and add autocomplete="off" it will not prompt for autocomplete.

 

eg. 

<form method="post" action="/form" autocomplete="off">

 

But I don't know how to add a parameter to the <form>.  I am assuming that somehow we are generating a HTML form.

Share this post


Link to post
Share on other sites

I don't know if it will autofill for you.  From reading about autofill it looks like it trys to match things saved by your browser that match the form.

 

So I named the fields Address, City, State, and Zipcode.

 

For me, it suggests items to autofill

AutoFill.zip

post-4889-0-97698700-1512700067_thumb.png

post-4889-0-40354500-1512700177_thumb.png

Share this post


Link to post
Share on other sites

Hi.

 

One possible solution:

 

MainmForm -> ClientEvents -> UniEvents -> Ext.form.Panel [form] -> function form.afterCreate:

function form.afterCreate(sender)
{
    sender.element.dom.setAttribute('autocomplete', 'off');
}

Try,

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×