Jump to content


Photo

Runtime 1413 and app previous to 1413

1413

  • Please log in to reply
4 replies to this topic

#1 Georges Soares

Georges Soares

    Active Member

  • uniGUI Subscriber
  • PipPipPip
  • 59 posts
  • LocationCuiabá-MT

Posted 11 October 2017 - 09:01 PM

I believe that due to adjustments to the date components in 1413, it causes a filter error if the application is compiled in the previous version.
 
My application is compiled in 1410, and I updated the server with Runtime 1413, the filters in the database that uses date as parameter was fetching date totally out of the requested.
 
just recompiled the application in 1413 and post to the server and everything went ok.
 
this is only an information post in case the same error occurs with your application.

  • 0

#2 Farshad Mohajeri

Farshad Mohajeri

    Administrator

  • Administrators
  • 9719 posts

Posted 12 October 2017 - 01:08 PM

Hi,

 

You should never use runtime from a different version.


  • 0

#3 Georges Soares

Georges Soares

    Active Member

  • uniGUI Subscriber
  • PipPipPip
  • 59 posts
  • LocationCuiabá-MT

Posted 13 October 2017 - 01:14 PM

Hello, I understand, but it is not easy, because I have several applications running on the same server, some already finished and others in development, then when I need to upgrade the server to the new ones, I need to remember to recompile all the other old applications. But the post was more to inform the community even if to happen to someone, already know what to do. Thank you Farshad.
  • 0

#4 delagoutte

delagoutte

    Advanced Member

  • uniGUI Subscriber
  • PipPipPipPip
  • 284 posts

Posted 13 October 2017 - 02:11 PM

hi ,

as 

Georges Soares, i have many install of runtime on my production server with many app that was compiled with many version of unigui.

Attached File  uni.png   85.34KB   2 downloads

 

but if I am not mistaken, there is not a problem because all app calls the unigui version with which it was compiled.(unless you have changed the default paths in your app config)

an app compiled with unigui 1.0.0.401 call the the files in directory uni-1.0.0.401 

 

farshad, 

i don't see the problem having many version of framework on server. could you explain ?


  • 0

#5 Delphi Developer

Delphi Developer

    Advanced Member

  • Moderators
  • 3178 posts

Posted 13 October 2017 - 02:30 PM

Hi,

... the version of the compilation and the runtime version should be the same

Best regards,
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users