Jump to content

Deployment standalone problem


Recommended Posts


1) I wanted to deploy the trial unigui standalone app on the PC of the potential customer but failed.

I did everything according to the unigui deployment doc:

set the TUniserverModule vars:

  ServerRoot := 'c:\Program Files\MyApp\';
  ExtRoot := '.\Uni\[ext]';
  UniRoot := '.\Uni\[uni]';
  CacheFolder := '.\Uni\';
  FilesFolder := '.\';
  TempFolder := '.\Uni\Temp';

then copied to 'c:\Program Files\MyApp\Uni\' directory the Unigui  and ExtJs directories:

'ext-' and 'uni-'


All I can see in the browser is the "Loading..." screen.

I checked it on the other PCs with the same result


Internet Explorer shows a small warning icon in the status bar telling that the page contains errors like

'Ext' - definition is missing


2) I tried to do the same on my PC with Delphi removing and restoring FMSoft directory from Program Files and found that

sometimes(!) it works fine and sometimes I get the same"loading..." message. I could not find the rule but when the FMSoft directory is present the app is working in 100% cases.


Did I miss something?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...