Jump to content
uniGUI Discussion Forums
Sign in to follow this  
Sistema Fenix

Isapi IIS restarting with frequency

Recommended Posts

Hi Fashard,

 

I have this problem a long time, but this latest version is more frequent.

fenix14.dll: 00002594: 08:19:26 [177.10.209.183]:UniErrorException : Event:click, Object: O1547 not found in session list. It could be timed out, refresh page and try again : Addr: $00000000
fenix14.dll: 00002124: 08:20:00 []:>--------------------------------------------------------------<
fenix14.dll: 00002124: 08:20:00 []:Starting Server. Module Handle: 0000000002710000
fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Server First Init.
fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Erasing Cache Folder...
fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Cache Folder Erased. <3158> Files deleted.
fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:HTTP Server not Started!
fenix14.dll: 00002124: 08:20:00 []:Server Started. Module Handle: 0000000002710000
fenix14.dll: 00001AC4: 10:28:37 [177.43.138.249]:UniErrorException : Event:click, Object: O3BD9 not found in session list. It could be timed out, refresh page and try again : Addr: $00000000
fenix14.dll: 00002F90: 10:29:41 []:>--------------------------------------------------------------<
fenix14.dll: 00002F90: 10:29:41 []:Starting Server. Module Handle: 0000000002280000
fenix14.dll: 00002F90: 10:29:41 [TUniServerModule]:Server First Init.
fenix14.dll: 00002F90: 10:29:41 [TUniServerModule]:Erasing Cache Folder...
fenix14.dll: 00002F90: 10:29:42 [TUniServerModule]:Cache Folder Erased. <4892> Files deleted.
fenix14.dll: 00002F90: 10:29:42 [TUniServerModule]:HTTP Server not Started!
fenix14.dll: 00002F90: 10:29:42 []:Server Started. Module Handle: 0000000002280000
fenix14.dll: 00002E04: 11:18:34 [HttpExtensionProc[191.177.186.15]]:EUniSessionException : Sessão expirada ou tempo de sessão esgotado. : Addr: $026A5FE3
fenix14.dll: 00001164: 11:26:21 []:>--------------------------------------------------------------<
fenix14.dll: 00001164: 11:26:21 []:Starting Server. Module Handle: 0000000002910000
fenix14.dll: 00001164: 11:26:21 [TUniServerModule]:Server First Init.
fenix14.dll: 00001164: 11:26:21 [TUniServerModule]:Erasing Cache Folder...
fenix14.dll: 00001164: 11:26:22 [TUniServerModule]:Cache Folder Erased. <4228> Files deleted.
fenix14.dll: 00001164: 11:26:22 [TUniServerModule]:HTTP Server not Started!
fenix14.dll: 00001164: 11:26:22 []:Server Started. Module Handle: 0000000002910000
fenix14.dll: 00002F2C: 12:38:34 []:>--------------------------------------------------------------<
fenix14.dll: 00002F2C: 12:38:34 []:Starting Server. Module Handle: 00000000027E0000
fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Server First Init.
fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Erasing Cache Folder...
fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:Cache Folder Erased. <1278> Files deleted.
fenix14.dll: 00002F2C: 12:38:35 [TUniServerModule]:HTTP Server not Started!
fenix14.dll: 00002F2C: 12:38:35 []:Server Started. Module Handle: 00000000027E0000
fenix14.dll: 00002E38: 13:37:08 [191.177.186.15]:UniErrorException : Event:keydown, Object: O17CB not found in session list. It could be timed out, refresh page and try again : Addr: $00000000
fenix14.dll: 00002E64: 13:40:43 []:>--------------------------------------------------------------<
fenix14.dll: 00002E64: 13:40:43 []:Starting Server. Module Handle: 0000000002710000
fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Server First Init.
fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Erasing Cache Folder...
fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:Cache Folder Erased. <3741> Files deleted.
fenix14.dll: 00002E64: 13:40:43 [TUniServerModule]:HTTP Server not Started!
fenix14.dll: 00002E64: 13:40:43 []:Server Started. Module Handle: 0000000002710000

Log error IIS

Faulting application name: w3wp.exe, version: 8.5.9600.16384, time stamp: 0x52157ba0
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000
Faulting process id: 0x2504
Faulting application start time: 0x01d1971adce7901f
Faulting application path: C:\Windows\SysWOW64\inetsrv\w3wp.exe
Faulting module path: unknown
Report Id: 05081776-0316-11e6-80bd-00259047b90c
Faulting package full name: 
Faulting package-relative application ID: 

Best regards

Share this post


Link to post
Share on other sites

Hi

 

No, I am using 0.99.90.1291.

 

Farshad, you know any tool to find out what really did it occur?

 

I need to somehow get more details to assess whether something is in Unigui, Third Party Component, IIS or in my code.

 

I realized that if sharing the same pool with more than one application occurs more often this.

 

Best regards

Share this post


Link to post
Share on other sites

Hi

 

You need to narrow down your case.

For example, does removing any of the above components will resolve the issue?

Have you checked that FastReport is used in a compatible mode with uniGUI?

Share this post


Link to post
Share on other sites

Hi

 

This is not an option, I need to use these components.
They are critical to our software.
What I need are ways to find out what is causing it. I do several local tests and when it comes into production starts happen this.
And I do not can putting the program into production without these components.
I run stress test tool with 100 sessions in forms that use these components and does not occur this error.
 
Thanks

Share this post


Link to post
Share on other sites

Yes, I try to emulate what happens in the production environment.

I'm making some changes now to make more tests using the test tool stress.
I always do in my development environment, but better prepare a test environment on the server also.

Share this post


Link to post
Share on other sites

hi

I have this problem.do you solve it?

Run.dll: 00000D64: 02:08:04 []:>--------------------------------------------------------------<
Run.dll: 00000D64: 02:08:04 []:Starting Server. Module Handle: 0000000002090000
Run.dll: 00000D64: 02:08:04 [TUniServerModule]:Server First Init.
Run.dll: 00000D64: 02:08:04 [TUniServerModule]:HTTP Server not Started!
Run.dll: 00000D64: 02:08:04 []:Server Started. Module Handle: 0000000002090000

Share this post


Link to post
Share on other sites

 

hi

I have this problem.do you solve it?

Run.dll: 00000D64: 02:08:04 []:>--------------------------------------------------------------
Run.dll: 00000D64: 02:08:04 []:Starting Server. Module Handle: 0000000002090000
Run.dll: 00000D64: 02:08:04 [TUniServerModule]:Server First Init.
Run.dll: 00000D64: 02:08:04 [TUniServerModule]:HTTP Server not Started!
Run.dll: 00000D64: 02:08:04 []:Server Started. Module Handle: 0000000002090000

 

 

Sometimes IIS unloads all modules if there is a long period of inactivity.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×