Jump to content
uniGUI Discussion Forums
Sign in to follow this  
pro_imaj

Frame Üzerine Query Koymamalı mıyız?

Recommended Posts

Merhaba;

 

Notmalde MainModule ekranına query datasource vb bileşenleri koyarak işlem yapıyordum projeler büyüyünce bu sorun olmaya başladı. Bende ilgili Frame üzerine koyuyorum şöyle bir sorun oluyor.

 

Projeyi delphi tarafında her yeni açtığımda tüm query'ler

"Missing Connection or ConnectionString" hatası alıyorum.

 

Bunu böyle yapmamam mı gerekiyor.

 

Teşekkürler.

İyi çalışmalar.

Share this post


Link to post
Share on other sites

MainModule'de onuda mı Frame'e almalıyım?

 

Böyle olursa her frame'de bir connection sorun olmaz mı?

Share this post


Link to post
Share on other sites

Connection doğru yerdedir.

 

Bu sorun aslında Delphi ile alakalıdır. Açık olmayan Module'daki bileşenleri göremiyor.

Aynı sorunu bir VCL projesinde de yaşarsınız.

 

Çözümü şu olabilir. Query'leri tasarım anında Active->True olarak kullanmayın.  Active False olsun sonra runtime'da kodda Active yapın.

Share this post


Link to post
Share on other sites

Teşekkür ederim.

Söylediğiniz şekilde geliştirmeye devam edeceğim.

 

Saygılarımla.

İyi çalışmalar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×