Jump to content
uniGUI Discussion Forums
Sign in to follow this  
erdal

Unigui approot error

Recommended Posts

Login form da iken, modalresult:=mrok satırında hata mesajı veriyor.

Yardımcı olabilirmisiniz.

Hata: Tanımsız veya boş bir referansın Approot özelliği alınamıyor.

Share this post


Link to post
Share on other sites

Bu Delphi'den gelen bir mesaj mı?

 

Login form da iken, modalresult:=mrok satırında hata mesajı veriyor.

Yardımcı olabilirmisiniz.

Hata: Tanımsız veya boş bir referansın Approot özelliği alınamıyor.

 

Uygulamanız bu hatayı veriyor olabilir mi? Bizde bu şekilde bir hata kodu yok.

Share this post


Link to post
Share on other sites

Merhabalar,

unigui eski sürümlerde mail gonderirken hata vermiyordu. simdi Ajax error diye bir hata dialog aciliyor.

 
Cannot read property 'appRoot' of undefined
 

içerisinde bu hata yazıyor. ama mailide göndermiş oluyor

 

unigui version : 0.98.10.1132

Share this post


Link to post
Share on other sites

unigui Log dosyasının içerisi boş . Hatayı verdikten sonra ilgili formu kapattirmiyor. mecburen browser i refresh etmek zorunda kaliyorum.

 

sanirim ondan kaynakli 


:EUniSessionException : Geçersiz Oturum veya Oturum Zaman Aşımına Uğradı

log dosyasında yukarıdaki hata var sadece.

 


Cannot read property 'appRoot' of undefined

bu hata verdikten sonra

post-962-0-55898800-1426841542_thumb.png

 

bu ekran çıkıyor. sonrasında nereye tıklasam işlem yapmıyor ve dialog tekrarlıyor.

Ayrıca bazen bir formu aciyorum. kapat butonuna tıkladığımda resimdeki dialog cikiyor. ama TAMAM diyip çalışmaya devam ediyor.

Bu sorun surekli cikmiyor. arasıra cikiyor. bazen 5-10 deneme de bir bazende her tıklayışımda çıkıyor.

 

Resimdeki hata mesajı unigui ile yaptigim tum uygulamalarda çıkıyor(appRoot diyen hatadan bağımsız. sadece resimdeki hata). Öncelerde internet bağlantısı ile ilgilidir diye düşünüyordum ama localde de aynı sorunlar çıkıyor.

Share this post


Link to post
Share on other sites

Bir ekran düşünün, kullanıcı adi ve sifre girilen. kişi bilgileri girip tamam butonuna bastığında database de sorgu yapip. kullanici varsa sadece mainform daki butonlarin ve panellerin visible ozelliği true yapip kullanıcı giris formunu kapatiyor.

bazen bunda da aynı hatayı aliyorum.

Share this post


Link to post
Share on other sites

Öncelikle şu an mevcut olan build 1160'a geçiş yapın.

Sorun devam ederse tekrar bilgi verin daha yakından inceleme yaparız.

 

Yalnız şu genel kuralı unutmayın:

 

LoginForm'dan MainForm'u çağırmak doğru değildir. Her ne kadar çalışıyor görünse de en iyisi Formlar arasında MainModule üzerinden veri paylaşımı yapmaktır.

Share this post


Link to post
Share on other sites

TUniLoginForm kullanmıyorum. mainform'un oncreate olayinda ayri bir form cagiriyorum. login islemleri icin o formu kullaniyorum. ama bu sorun sadece login ekraninda degil. program icerisindeki herhangi bir ekranda da baslarken veya kapatirken verebiliyor.

 

peki "mainform'un oncreate olayinda ayri bir form cagiriyorum." bu sekilde kullanmak uygun mudur?

1160'a geçiş yapıp sonucu bildireceğim.

Teşekkürler.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×