Jump to content

Version 0.88.1.943 is available for download


Farshad Mohajeri
 Share

Recommended Posts

  • Administrators

http://www.unigui.co...r-version-0-88/

 

0.88.1.943

+----------------------------------------------------------------------------------------

- 0001282: Form's values aren't synced when deactivated.

- 0001281: UniTreeView: MainForm.Close in OnClick event.

- 0001203: UniTabSheet: PageIndex bug.

- 0001261: OnDropDown event for ComboBox.

- 0000640: UniSession SendFile() method

- 0001284: UniSession SendStream() method.

- 0001268: UniDateTimePicker: ShowBlankDate property.

- 0001270: UniDBGrid: Float/number field ignores decimal/thousand separators.

- 0001042: Grid Cell font changes when editing cell.

- 0001274: UniDBGrid: Embedded editor's Font doesn't match Grid's Font.

- 0001278: TUniToolButton: Transparency Property.

- 0001279: Bug when received string contains a "&".

- 0001280: Critical bug in Form parameter setting logic.

- New Demo: DownloadDemo-2

Link to comment
Share on other sites

I need your help i can't install uniGUI 0.88.1.943

 

After updating Delphi XE2 with Update 4

i tried to install uniGUI 0.88.1.943.

 

First i deinstalled the old version of UniGUI 0.88.0.917

Then i installed Version 0.88.1.943.

I checked that all path are set.

 

Every time i compile the Group uniGUI2012Group i get following error:

 

[DCC Fataler Fehler] SynEdit_R2012.dpk(30): E2225 'Never-build' Package 'designide' muss neu compiliert werden

[DCC Fataler Fehler] SynEdit_D2012.dpk(35): E2202 Package 'SynEdit_R2012' wird benötigt, konnte aber nicht gefunden werden

 

You can see , its a german Version of Delphi

the rough translation of the Error Message is:

 

 

[DCC fatal error] SynEdit_R2012.dpk(30): E2225 'Never-build' Package 'designide' need to be compiled

[DCC fatal error] SynEdit_D2012.dpk(35): E2202 Package 'SynEdit_R2012' is used, but couldn't be found

 

This message is generated, when the secound file SynEdit_D2012.bpl

is compiling

 

I tried some times to deinstall it and reinstall. But the error is the same.

 

Do you have an idea what i can change ?

 

Thanks in advance for your comments

Link to comment
Share on other sites

You need to build all packages starting from SynEdit_R2012. Simply call Build All command.

 

Allready tried with Build all, but the error is the same.

I tried to build all, and i get the error. I tried to build line by line

and get the error

Link to comment
Share on other sites

I will send you a private message.

Dear Farshad,

 

thank you very much for your help.

 

I tried some more with my installation, but

i think the Delphi XE2 Update 4 was the Problem and

killed something.

 

Today i installed a complete new Delphi XE2 with included Update 4

and then i could install the uniGUI without any problems.

Then i tried to install all other Software packages like

TMS, LMD, Clever Suite, Next etc. everythink works fine.

Afterwords i deinstalled the uniGUI and installed it once more,

and it works.

 

Since october last year, when i found your uniGUI Components i'm

a fan of them - thanks for your perfect work

Link to comment
Share on other sites

  • 2 weeks later...

 

[DCC Fataler Fehler] SynEdit_R2012.dpk(30): E2225 'Never-build' Package 'designide' muss neu compiliert werden

[DCC Fataler Fehler] SynEdit_D2012.dpk(35): E2202 Package 'SynEdit_R2012' wird benötigt, konnte aber nicht gefunden werden

 

You can see , its a german Version of Delphi

the rough translation of the Error Message is:

 

 

[DCC fatal error] SynEdit_R2012.dpk(30): E2225 'Never-build' Package 'designide' need to be compiled

[DCC fatal error] SynEdit_D2012.dpk(35): E2202 Package 'SynEdit_R2012' is used, but couldn't be found

 

 

if you got this right click every package, add dcp output to $(fmsoft)\uniGUI\Dcu\Delphi2012

 

i got this problem on delphi xe2 starter edition,,, everytime i compile i got this error "'Never-build' Package 'xxx' need to be compiled"

after add i got success all, i dont know this is bug xe2 or not, this is not only unigui package but also jedi etc

Link to comment
Share on other sites

  • 3 weeks later...

This happends because there is not path to the dcu file generated with the first build. So you need to add the directory in Tools/options/delphi options/library/ --> library path. Probably is C:\Users\Public\Documents\RAD Studio\9.0\Dcp

 

 

 

http://www.unigui.co...r-version-0-88/

 

0.88.1.943

+----------------------------------------------------------------------------------------

- 0001282: Form's values aren't synced when deactivated.

- 0001281: UniTreeView: MainForm.Close in OnClick event.

- 0001203: UniTabSheet: PageIndex bug.

- 0001261: OnDropDown event for ComboBox.

- 0000640: UniSession SendFile() method

- 0001284: UniSession SendStream() method.

- 0001268: UniDateTimePicker: ShowBlankDate property.

- 0001270: UniDBGrid: Float/number field ignores decimal/thousand separators.

- 0001042: Grid Cell font changes when editing cell.

- 0001274: UniDBGrid: Embedded editor's Font doesn't match Grid's Font.

- 0001278: TUniToolButton: Transparency Property.

- 0001279: Bug when received string contains a "&".

- 0001280: Critical bug in Form parameter setting logic.

- New Demo: DownloadDemo-2

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...