Jump to content
uniGUI Discussion Forums
stlcours

Can I run .dll in Apache2 in Linux?

Recommended Posts

Hi,

 

First question, can it(.dll) run in apache2 in Linux?

I tried to run .dll in Apache2 in Linux. So it should modify "httpd.conf":

 

LoadModule isapi_module modules/mod_isapi.so

 

AddHandler isapi-handler .dll

 

<Directory "\home\myapp">

Options Indexes FollowSymLinks ExecCGI

AllowOverride None

Order allow,deny

Allow from all

</Directory>

 

Alias /mywebapps "\home\myapp"

 

But I cannot find the folder "modules" in \etc\apache2, and alos there is none of "mod_isapi.so".

I use ubuntu 10.04 and apache2.2.14, but I don't know how to install the package "mod_isapi.so".

When I tried to "sudo apt-get install libapache2-mod-isapi", but it is not there. How should I do for continue? (it can already run PHP).

Thanks...

 

Best regards.

Share this post


Link to post
Share on other sites

What kind of Application are you running in apache ?

Does Your Application connect  to a Database if So then what kind of are you using, ADO, DbExpress or other kind

 

Ronny Encarnacion

Share this post


Link to post
Share on other sites

Yes, I use Firebird with Zeos.

 

Actually I am having a little bit of troubleshooting, because my app loads settings for the database connection from ini files and I get some strange errors, that I am not having when I run it as an exe on the same linux server using wine. Perhaps apache rights stuff.

I'll be back when it runs 100%

Share this post


Link to post
Share on other sites

Well,

 

when you install wine at linux, creates automatically on .wine folder, a folder called drive_c. At this folder I create a folder for my application, copy all the files and folder in there, including ext folder. Works fine.

Moreover I try to install it as an apache dll but as I have mentioned at post #13 I have some issues. I didn't find the time to troubleshoot because I working right now on another project. When I have something newer I will come back!  :) 

Share this post


Link to post
Share on other sites

Hi, after a lot of effort, I get the error canot load dynamic libraries fbclient.dll etc, because I use zeos and firebird database. I try several things by loading using TZConnection.LibraryLocation but still the errors exist. The strange thing is that when I execute at the same server, same path, the exe file works fine, but the dll using apache....still nothing. :unsure:

If someone can suggest something... I will be pleased.

 

Share this post


Link to post
Share on other sites

At last it works!!! :D

 

in the LibraryLocation I should state not only the folders, also the filename (eg. /home/userxxxx/FBCLIENT.DLL).
 

and when a new dll file is uploaded, apache needs a restart.

 

So, running a dll in a linux box can be done!!!

Share this post


Link to post
Share on other sites

Hi, it's been a long time but I will try,

 

I try it on Ubuntu 12.04

Firstly install wine

then you must install apache for windows using wine, wine msiexec -i apache.msi,

then you place extjs folder and your application the same way like iis.

 

Unfortunately, I abandoned this solution because I've got this problem

http://forums.unigui.com/index.php?/topic/3475-icons-on-isapi-dll/?hl=apache

and never found a solution.

Share this post


Link to post
Share on other sites

skepsis

Thank's I yesterday run as like standalone server on VPS Linux Ubuntu 12.04 minimal..

Working now 250 RAM 750 CPU 10000 GB HDD

 

Step

1) Install ubuntu 12.04 minimal

2) Install Mysql

3) Install wine

4) Install XFCE with vncserver

5) Download for windows vncviewer for connect from my Windows to VPS server

6) Upload my unugui.exe and runtime exjs and install with Wine Programm loader

 

Thank's for all

Share this post


Link to post
Share on other sites

×