Jump to content

HyperServer Response about INI file


Recommended Posts

 

After several months of porting various programs to have web interfaces (for cloud deployment)

we are ready to delve into the world of deployment.

Our first step is to try out HyperServer - running our app compiled in simple stand-alone mode.

Of course the simple steps are quite clear:

Copy hyper_server.exe and hyper_server.cfg to folder where your application's executable file resides.

Compile your application in Standalone Server mode. You may need to change your project's DPR file to switch from a different mode to Standalone Server.

Edit hyper_server.cfg file and set binary_name parameter to your application's executable name. For example binary_name=myapp.exe

Again hyper_server.cfg file set prompt_login=0

Run hyper_server.exe

In a browser tab navigate to url http://localhost:8077

You should be able to see your app's main form or login form in browser tab.

[Eventually we figured out that the FMSOFT_uniGUI_xxxx_runtime_xxxx.exe needed to be installed. OK.]

Bingo,  now     localhost:8077\server    gets us to the management console nicely.

But when we hit our app with   localhost:8077  we consistently get a curious message:

Expected values not found in config file: C:\Program Files\HyperServer\wValupay.ini

Our app is called wValupay.exe   but is this some sort of necessary file we must create?

If so, I have just missed all mention of it somehow!  What would go in there?

complete version  1.90.0.1499

 

We do love uniGUI,

tonyM

 

 

 

Link to post
Share on other sites
×
×
  • Create New...