Jump to content

Error 404 For IIS ISAPI Deployment


Recommended Posts

I am deploying my application with HyperServer ISAPI in IIS 10 and the physical directory is C:\UNGAPPS. When typing http://localhost/hello.dll from the web browser, why does the browser select the wrong physical path and return a 404 error? I have followed the instructions from the developers' manual. 

IIS displays the default page when I type http://localhost.

--
Frederick
(UniGUI Complete - Professional Edition 1.90.0.1508)
 

Error 404.png

Link to post
Share on other sites

I am answering this topic myself for the benefit of users who may have a similar question.

In the IIS manager, the basic setting of the application contains an alias field. In my case, it is "hello". If my application's name is xyz.dll, calling up the application locally will require me to type the following URL in the web browser:-

localhost/<alias>/xyz.dll where <alias> is hello.

If I do not want to type xyz.dll each time, I can add xyz.dll as a default document of the application. My URL will then be:-

localhost/hello

If you are calling the application over the Internet, replace "localhost" with the IP address or domain name of the host. If over a network, replace "localhost" with the network address of the host.

Link to post
Share on other sites
×
×
  • Create New...