Jump to content
uniGUI Discussion Forums
Abaksoft

Delphi TOKYO VERY SLOW ON WINDOWS 10 ?

Recommended Posts

Dear Friends,

Not related to Unigui. But wanted, maybe your expertise.Delphi_TOKYO_Slow_On_win_10.thumb.png.29b7d2d8c74fcf19251f01ddba15497b.png

I have just installed my Delphi Tokyo 10.2 update 3   Build  25.0.29899.2631

on my new Hard Disk, freshly formated with  Windows 10 Pro / 64  (Official OEM Licence KEY).

On a good machine :  i3  processor 64 bit   8 GO RAM

Result:   it take 7 minutes  to only  lauche  bds.exe   !!!

 - No antivirus

- Windows Defender disabled

- FireWall disabled

- UAC disabled

- Bds.exe  Security -->  Full Control (all users)

Oh… what happened  ?

Thx for advises...

Share this post


Link to post
Share on other sites

Maybe the CPU: i3 you need i7

Share this post


Link to post
Share on other sites
1 hour ago, Abaksoft said:

Dear Friends,

Not related to Unigui. But wanted, maybe your expertise.Delphi_TOKYO_Slow_On_win_10.thumb.png.29b7d2d8c74fcf19251f01ddba15497b.png

I have just installed my Delphi Tokyo 10.2 update 3   Build  25.0.29899.2631

on my new Hard Disk, freshly formated with  Windows 10 Pro / 64  (Official OEM Licence KEY).

On a good machine :  i3  processor 64 bit   8 GO RAM

Result:   it take 7 minutes  to only  lauche  bds.exe   !!!

 - No antivirus

- Windows Defender disabled

- FireWall disabled

- UAC disabled

- Bds.exe  Security -->  Full Control (all users)

Oh… what happened  ?

Thx for advises...

It' not a machine for Developer I3 is to Slow If want perfomance you must get I7 and 16GB RAM and SSD Disk 

 

 

Share this post


Link to post
Share on other sites

i have i3 and mine runs fairly fast, maybe something wrong with windows on your machine

Share this post


Link to post
Share on other sites

To me its verrrrrrry slow , I7 32GB SSD , nothing solved.... every compilation i have to take a cofee

Share this post


Link to post
Share on other sites

Solved :)

bds.exe  must be launch with only one CPU  !

CPU Affinity CPU=0

Thx to Javorszky

https://community.embarcadero.com/forum/installation-issues/1408-running-from-ide-freezes-windows-10#4173

 

Edit :

To run quickly without entring  TaskManager and change Setting CPUAffinity,

just create a batch file on the desktop:

cd "C:\Program Files (x86)\Embarcadero\Studio\19.0\bin\"
start /affinity 1 bds.exe

 

Why ?

"The reason for this is that most applications you run these days have been designed with multi-core processors in mind and will work with the operating system to distribute their operations as evenly as possible across all the available cores. "

see :   https://www.techrepublic.com/blog/windows-and-office/change-the-processor-affinity-setting-in-windows-7-to-gain-a-performance-edge/

  • Upvote 1

Share this post


Link to post
Share on other sites

YEEESSSSS.... literaly the compilations jumped from 3 minuts each to 6 seconds !!! , thanks !!! 

 

I thinks that this post should be fixed on top of this forum... a lot of people have the same problem.

Share this post


Link to post
Share on other sites
On ‎9‎/‎27‎/‎2018 at 10:23 AM, Abaksoft said:

Solved :)

bds.exe  must be launch with only one CPU  !

CPU Affinity CPU=0

Thx to Javorszky

https://community.embarcadero.com/forum/installation-issues/1408-running-from-ide-freezes-windows-10#4173

 

Edit :

To run quickly without entring  TaskManager and change Setting CPUAffinity,

just create a batch file on the desktop:

cd "C:\Program Files (x86)\Embarcadero\Studio\19.0\bin\"
start /affinity 1 bds.exe

 

Why ?

"The reason for this is that most applications you run these days have been designed with multi-core processors in mind and will work with the operating system to distribute their operations as evenly as possible across all the available cores. "

see :   https://www.techrepublic.com/blog/windows-and-office/change-the-processor-affinity-setting-in-windows-7-to-gain-a-performance-edge/

 

 

Important :

if you want an Elevate Administrator  (Project > Options > Application > Manifest) :

Elevate_Admin.png.ab878b5f270dbb1cb439983bc8cfc072.png

 

You have to  Run your shortCut (batch File)   as Administrator  :

AsAdmin.png.9832f45b4dcc118d5b3231cfa9aee04f.png

  • Upvote 1

Share this post


Link to post
Share on other sites

Just to complete the useful observation of Abaksoft .

I use in the menu tools to call a bat that compress the exe and send to distribution directory to be automaticaly updated in the stations. The problem of calling delphi in a bat is that if i call a bat inside the ide delphi it not receive the administrative privileges , so no pack or delete was possible, after some research i changed the call of pack.bat with the use of psexec

 

image.thumb.png.8c7a031f6c48159e6c35839e37d78d63.png

The parameter like is

\\fabio_d64 -u fezer\fabio -p YOURPASSWORD c:\dpd_10\pack.bat $PROMPT()

image.thumb.png.a626c3e8b618e0c90108db2afa8a7946.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×