Jump to content

Export Pdf sometimes data display 0


Recommended Posts

hi,

 i got a weird case, when user export data to pdf (fast report) sometimes data display incorrectly, ex.the money display 0.00 on the whole page

but after restart IIS everything go back to normal. i've checked  Unigui log or IIS log not found any errors.

 

 

***************

Environment

***************

Unigui 1.0.0.1399

Delphi Tokyo 10.2

Database Firebird

Fast Report 5.x

IIS 6 Windows Server 2003

Link to post
Share on other sites

It happened to me when I swiched from one database to another.

It looked as if in the app the connection to the database displayed the right data but

the FastReport connector remained on the previous connection (???) .

I solved the issue by including a frx database connection in each the report and changing parameters for

the connection to the new database in the report before actually running the report.

Of corse I can' say if it's your case. Just an ideea.

Link to post
Share on other sites

It looked as if in the app the connection to the database displayed the right data but

the FastReport connector remained on the previous connection (???) .

Hi adragan,

Yes it is. database display the right result, but not for fast report.

I will try your solution.

 

thank you

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...