Jump to content

Search the Community

Showing results for tags 'isapi'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • uniGUI Public
    • Announcements
    • General
    • Feature Requests
    • Installation
    • Deployment
    • Other Platforms
  • Licensing
    • Licensing
    • Ordering uniGUI
  • Bug Reports
    • Active Reports
    • Closed Reports
    • Old Bug Reports
  • uniGUI Development
    • uniGUI 1.x
    • Beta Releases
    • Utilities
  • Mobile Platform
    • uniGUI Mobile
    • Mobile Browsers
  • Users Area
    • Sample Projects
    • Components and Code Samples
  • Non-English
    • Non-English
  • Miscellaneous
    • Hosting
    • Server Security
    • Jobs

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 20 results

  1. Hello, I am a bit clueless with a big problem I need to solve ASAP. The current situation is as followed. I am running on a Windows 2016 server two uniGui Applications. One works as a non visual DB server, which feeds an external PHP Shop Application with information like articles , prices, etc. The other one is a Backend Application, which handles all the articles from the shop. So this behaves more like the standard uniGui Application we all know, using all the nice uniGui visual components we all love. But my problem comes from the non visual application, which sometimes is no
  2. Hola, Hemos activado el hyper_server en modo ISAPI y no somos capaces de acceder al monitor del mismo. La URL que usamos desde nuestro servidor es: http://localhost/server ¿No es correcto? Un saludo
  3. Hi I need a clear step by step instructions to do the following: 1- Create ISAPI web page and run it on mylocal host. 2- a list of ISAPI hosting companies. 3- How to deploy my ISAPI on my hosting space. And finally How to MIX HTML design with MYGUI components such as Buttons .... Thanks
  4. Hello Friends... I am developing an UniGUI application that uses FastReport (frxReport & frxPDFExport components). The ISAPI App work properly in IIS 7.5 (Windows 7); But when I deployed my App on IIS 10 (Windows 10), when the App want to Exporting PDF, fully stopping working (Without any Exception). Exception is in this line: frxRreport.ExportPDF(frxPDFExport); This issue solve when I Using FastReport version 4; But I need higher version in my project (5 or 6). Notice: I give Full Permission to IIS directoy for IIS_USRS & IUSR; So PDF file created in Cache
  5. Hi, 1. I compile the most basic uniGUI application (this means, I create a new uniGUI application with the Application Wizard and choose ISAPI module) 2. I transfer by ftp the compiled project1.dll file to my wwwroot on Azure 3. I try to connect with my webbrowser: https://xxx(mypath).azurewebsites.net/project1.dll I expect to see my compiled MainForm in my browser, the only thing I see is an empty white webbrowser with the message : loading... What am I doing wrong ? What other files have to be transferred ? Thank you in advance. cdev
  6. Hi, I'm having trouble with my isapi application that is going down when total/active threads reaches it's max like the attached image. What does make it go high and freeze application? Is there any documentation how to configure the ThreadPoolSize? All the components that I'm using in the project; - ADOComponents - SQL Server 2005/2008 (depends the customer) - Report Tools QuickReport 5.05.1 and Rave Reports 10.0 - TClientDataSet
  7. professional 1.0.01425 app working good when working as standalone but when i change it to isapi dll fire this exception: Failed to delete tab at index 0
  8. Hi, Can someone explain what is the property ISAPIOptions -> AsyncMode, in Server Module ? I had a problem with ExportToFilter(quick report), then checking option to 'true', I solved this.
  9. Hi everyone, i need your experience in this component. I have compiled a project with uniDAC in standalone server and working ok, but, when the project is uniDAC in ISAPI Module i have the error: "GDS function is not linked" I used firebird, delphi xe10.2 and uniDAC 7.0.2. I will be grateful if someone can give me information or an example of how to make it work. thanks in advance.
  10. Hi all, We try to deploy ISAPI dll to Apache PHP Version 5.6.30. On MainModule is placed AdoConnection and connected Queries components to access MS SQL database. From log files I can see that application crash (access violation) just after AdoConnection is open. Of course on server module AutoCoInitialize is set to True. In the same time app run on IIS or standalone server without any problem, but on Apache is crash. Anybody has idea what could be wrong? Development environment: UniGui: 0.93.1.1000 Delphi Xe2 DB: MSSQL
  11. Hi, I currently have a project that i created as a service, is there a easy way to convert the project to a ISAPI module? Best regards Christian J
  12. Hi Fashard, I have this problem a long time, but this latest version is more frequent. fenix14.dll: 00002594: 08:19:26 [177.10.209.183]:UniErrorException : Event:click, Object: O1547 not found in session list. It could be timed out, refresh page and try again : Addr: $00000000 fenix14.dll: 00002124: 08:20:00 []:>--------------------------------------------------------------< fenix14.dll: 00002124: 08:20:00 []:Starting Server. Module Handle: 0000000002710000 fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Server First Init. fenix14.dll: 00002124: 08:20:00 [TUniServerModule]:Erasi
  13. Hello, I've created Standalone Application at the start and then I tranformed it into a ISAPI module (comment line for GUI in project source) witch I've put on IIS 7.5. When I call .dll first form shows as it should, but when I click some data on DBGrid it should open new form with details of that record. In standalone app works fine, but as ISAPI modulu it doesn't. I've checked log and there is this. Workflow: 00001E24: 07:23:21 []:-------------------------------------------------------------- Workflow: 00001E24: 07:23:21 []:Starting Server. Module Handle: 00000000022A0000 Workflow.d
  14. Hello, how could I simply change from Standalone version to ISAPI modulu without moving the code from project to project.
  15. Hello UniGuys, I have some questions about the configuration of a unigui isapi modul in IIS (7.5, or 8.0). in the log of my deployed dll i find entries like this: adm: 00002FD0: 10:25:13 [HttpExtensionProc[31.25.121.236]]:EUniSessionException : Invalid session or session Timeout. : Addr: $01EFDC44 adm: 00000DFC: 10:36:41 [HttpExtensionProc[31.25.121.236]]:EUniSessionException : Invalid session or session Timeout. : Addr: $01EFDC44 i set my Application pool in IIS with following settings (Process Model): idle Timeout (minutes) -> 2 Idle Timeout Action -> Terminate so after 2
  16. Publiquei a DLL no Meu Computador Funcionou ok. No servidor Erro 500.19 Mudei as permissões do usuário e agora não dá erro mas fica carregando .... e não mostra nada depois de um tempo TimeOut. O Servidor está funcionando ok, tenho outro site, mas não em ISAPI. http://www.empresamix.ws/UNIGUI/web_aluno.dll
  17. Could anyone that has successfully deployed a uniGUI ISAPI dll to Azure please provide the steps and example that you used to create the package and service definition schema? I'd like to deploy my app to an Azure web role instead of VM but having a difficult time doing it. Thanks! Robert
  18. Hi Forum! This is the case: A HTML page with ASP define variables, Session variables. code: <html> <% Dim urlname urlName = "localhost:/cgi-bin/mydll.dll" Session("virtualSnipper") = MySnipperFunction(Session.id) %> <head> <title>My Title</title> </head> <body> <iframe name="framei" id="framei" frameborder="0" width="100%" height="98%" src="<%=urlName %>"> </iframe> </body> </html> When mydll.dll (an unigui web application) is called, the session has defined "virtualSnipper
  19. Hello everybody! Please, I'm racking my brains to solve the date format. At the date VCL is exactly as I want, but when I compile and publish in IIS format is completely different. Have I set the regional settings of the server, but to no avail. Thanks for your help.
  20. When I run the ISAPI mode parameter URL does not work, how can I solve this? Please ajuder me with solution.
×
×
  • Create New...